WRTnode2P 如何关闭AP

透过 setwifi 可使 WRTnode2P 成 AP + STA 状态
那么如何只让 WRTnode2P 只有 STA ?

我修改了/etc/config/wireless
config wifi-device 'ra0'
option type 'ralink'
option mode '9'
option txpower '100'
option ht '20'
option country 'US'
option disabled '0'
option channel '6'

config wifi-iface
option device 'ra0'
option network 'wwan'
option mode 'sta'
option ssid 'MyRouter'
option encryption 'psk2'
option key 'MyRouter'
option ApCliEnable '0'
option ApCliAuthMode 'WPA2PSK'
option ApCliEncrypType 'AES'
option ApCliSsid 'MyRouter'
option ApCliPassWord 'MyRouter'

与/etc/config/network
 
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd52:a9d3:158e::/48'

config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option macaddr '90:4e:91:40:c0:f2'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.8.1'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.2'
option force_link '1'
option macaddr '90:4e:91:40:c0:f3'
option proto 'dhcp'

config interface 'wwan'
option proto 'dhcp'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '0'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'

重启网路,但没有作用。
已邀请:

xzmu - 10w

赞同来自:

在wifi启动后ifconfig ra0 down即可。目前配置文件好像还不能只开sta

要回复问题请先登录注册