openwrt crontab 配置

最近编译了openwrt trunk版本下载进wrtnode,想起个定时器,用crontab,在网上看到openwrt默认不启动crontab的,用脚本查询启动情况:
root@OpenWrt:~# for F in /etc/init.d/* ; do $F enabled && echo $F on || echo $F **disabled**; done
/etc/init.d/boot on
/etc/init.d/bootcount on
/etc/init.d/cron on
/etc/init.d/dnsmasq on
/etc/init.d/done on
/etc/init.d/dropbear on
/etc/init.d/firewall on
/etc/init.d/gpio_switch on
/etc/init.d/led on
/etc/init.d/log on
/etc/init.d/network on
/etc/init.d/odhcpd on
/etc/init.d/sysctl on
/etc/init.d/sysfixtime on
/etc/init.d/sysntpd on
/etc/init.d/system on
/etc/init.d/umount **disabled**
/etc/init.d/urandom_seed on
可以看到cron是on 状态,但是crontab -e添加 */1 * * * * /root/test.sh任务后/root/test.sh并没有定时执行
执行/etc/init.d/cron start后任务开始执行。
请问这个/etc/init.d/cron 的on 状态为什么还要再/etc/init.d/cron start。如何让crontab开机就运行呢?谢谢
 
已邀请:

xzmu - 10w

赞同来自:

因为corntabs默认会启动,但是检查到没什么任务就自己退出了,所以你添加任务之后要么重启系统,要么启动cron

要回复问题请先登录注册