How to configure internet

I have connecto to device via via with original stock firmware.
I could not configure my router:

I have followed the Starting - WRTnode Wiki Site

/etc/config/wireless

config wifi-device 'ra0'
option type 'ralink'
option mode '9'
option channel '6'
option txpower '100'
option ht '20+40'
option country 'US'
option disabled '0'

config wifi-iface
option device 'ra0'
option network 'lan'
option mode 'ap'
option encryption 'psk2'
option key '12345678'
option ApCliEnable '1'
option ApCliSsid 'MY_ROUTER'
option ApCliAuthMode 'WPA2PSK'
option ApCliEncrypType 'AES'
option ApCliPassWord 'MyPwdINHex'
option ssid 'WRTnode253E'

root@OpenWrt:/etc/config# ia
apcli0 Link encap:Ethernet HWaddr 66:xx:7E:xx:xx:xx
inet6 addr: fxx::6xxx:7xx:xxx0:2xxx/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
 
UPDATE:
after few seconds I got ip, but still do not get internet
What do I need?
已邀请:

xzmu - 10w

赞同来自:

how did you detect your board not access the internet?

Zsolo

赞同来自:

ping google.com
 
opkg update
 
seems I do not have internet
 
Should it work by default or do I need something to configure?

xzmu - 10w

赞同来自:

setup wifi apcli connection or change switch's vlan

Zsolo

赞同来自:

I am posting my settings. Could you see any misconfiguration?
Could you tell me what should I change in 'network' to get internet via special RJ45 cable?
 

 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (Bleeding Edge, r41508)
 
 
 
root@OpenWrt:~# ifconfig
apcli0    Link encap:Ethernet  HWaddr 66:ee:dd:bb:aa:cc
          inet addr:192.168.0.161  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::6451:7eff:fe80:253e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
br-lan    Link encap:Ethernet  HWaddr 64:aa:nn:vv:aa:ff
          inet addr:192.168.8.1  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::6651:7eff:fe80:253e/64 Scope:Link
          inet6 addr: fd74:b1d4:7e82::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2095 errors:0 dropped:0 overruns:0 frame:0
          TX packets:433 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:162600 (158.7 KiB)  TX bytes:258708 (252.6 KiB)
eth0      Link encap:Ethernet  HWaddr 64:aa:nn:vv:aa:ff
          inet6 addr: fe80::6651:7eff:fe80:253e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:824 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:91163 (89.0 KiB)
          Interrupt:5
eth0.1    Link encap:Ethernet  HWaddr 64:aa:nn:vv:aa:ff
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:819 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:89672 (87.5 KiB)
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:151 errors:0 dropped:0 overruns:0 frame:0
          TX packets:151 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10888 (10.6 KiB)  TX bytes:10888 (10.6 KiB)
ra0       Link encap:Ethernet  HWaddr 64:aa:nn:vv:aa:ff
          inet6 addr: fe80::6651:7eff:fe80:253e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2369 errors:0 dropped:0 overruns:0 frame:0
          TX packets:413 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:248984 (243.1 KiB)  TX bytes:249752 (243.8 KiB)
          Interrupt:6
  
----
firewall
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1
config zone
option name lan
list   network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list   network 'wan'
list   network 'wan6'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option src_ip fe80::/10
option src_port 547
option dest_ip fe80::/10
option dest_port 546
option family ipv6
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
# include a file with users custom iptables rules
config include
option path /etc/firewall.user

### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT
# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT
# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP
# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp
# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp
# allow IPsec/ESP and ISAKMP passthrough
#config rule
# option src wan
# option dest lan
# option protocol esp
# option target ACCEPT
#config rule
# option src wan
# option dest lan
# option src_port 500
# option dest_port 500
# option proto udp
# option target ACCEPT
### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT
#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp 
--
network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd74:b1d4:7e82::/48'
config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.8.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option ifname 'apcli0'
option proto 'dhcp'
option macaddr ':'
config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'
  
--
wireless
config wifi-device  ra0
option type     ralink
option mode 9
option channel  6
option txpower 100
option ht 20+40
    option country US
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0
config wifi-iface
option device   ra0
option network lan
option mode     ap
option ssid     WRTnode253E
option encryption psk2
option key 12345678
option ApCliEnable '1'
option ApCliSsid 'MYRTR'
option ApCliAuthMode 'WPA2PSK'
option ApCliEncrypType 'AES'
option ApCliPassWord 'mypass' 

xzmu - 10w

赞同来自:

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 4 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '3 6t'
 
 
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

Zsolo

赞同来自:

Finally I have found out what caused it.

I have made access point from my Android phone and it does not has any problem. I got internet on wrtnode :)
If I use my TL-MR3220 wireless router then I do not have internet, but it got IP!

Any idea why??

|Channel:|Auto (Current channel 6)|
|---|---|
|Mode:|11bgn mixed|
|Channel Width:|Automatic|

I got few devices, but all of them working well..

ps: one question regarding network settings above
I have connected openwrt to the shield and it's intergrated lan port to one of my routers LAN port with standard RJ45 cable. I still do not have internet and the leds are not blinking. Are you mean this configuration?

要回复问题请先登录注册